カテゴリー
SugiBlog ホームページ制作・システム開発|大阪

PHP5.4以上でのクラスの継承

既に定義されたクラスを継承して子クラス(サブクラス)を作成し、メソッドを上書き(オーバーライド)する際は注意が必要です。

オーバーライドするメソッドは引数の数、デフォルト値の設定が異なるとエラーになります。

Strict Standards: Declaration of ... should be compatible with ...

というのも、PHP5.3まではOKだったんです。
5.3系から5.6系にアップグレードする際はご注意ください。

この記事がお役に立ちましたらシェアお願いします

209 views

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です